Answered By: Doug Bolden
Last Updated: Oct 07, 2015     Views: 54

What browser are you using?  Here are minimum browser requirements for EBSCO interfaces:

Internet Explorer 7.0 or later
FireFox 3.6 or later
Safari 5.0 or later
Google Chrome 14 or later
Other JavaScript, Cookies Enabled

The recommended screen resolution for EBSCOhost is 1024 x 768. See first note below for exceptions.

(Macintosh OS9 users who cannot run the latest Netscape version 7.2 can download a compatible version by clicking HERE, then clicking on the "Download Now" link inside right-hand column.)

How do I update my browser?

Notes:

  • The recommended screen resolution for Nursing Reference Center (NRC), Rehabilitation Reference Center (RRC), and Patient Education Reference Center (PERC) is 1280 x 1024.

  • Internet Explorer 8 users should turn off Compatibility View by clicking the button next to the web address bar in their browser. Compatibility View may cause some areas of EBSCO interfaces to not display correctly.

  • Mac users trying to open PDF files using the Safari 5.1 browser must install the Schubert|It PDF plug-in to view PDFs at this time.

  • Adobe Flash Player 8.0 or later is required to use Visual Search in EBSCOhost.

  • Adobe Flash Player 10.0 or later is required to use Text-To-Speech on interfaces in which it is available.

  • The Netscape browser is not supported by EBSCOhost, however some EBSCO applications may run using this type of browser.

  • Page Composer will not appear for users who do not have browsers that meet these requirements.


If you've tried another browser or updated your current browser and are still experiencing issues, please let us know at http://libanswers.uah.edu.


 

Contact Us

 

Other ways to contact us: